使用elasticsearch-rest-high-level-client 7.1.1版本遇到的问题,
在GitHub上发了个issues

这个在官方文档没有说清楚,
pom中加入依赖

<dependency>
   <groupId>org.elasticsearch.client</groupId>
   <artifactId>elasticsearch-rest-high-level-client</artifactId>
   <version>7.1.1</version>
</dependency>

还需要加

    <!-- https://mvnrepository.com/artifact/org.elasticsearch/elasticsearch -->
        <dependency>
            <groupId>org.elasticsearch</groupId>
            <artifactId>elasticsearch</artifactId>
            <version>7.1.1</version>
        </dependency>
Last modification:February 13th, 2020 at 03:44 pm
如果觉得我的文章对你有用,请随意赞赏